heater control bulbs - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 307
PeugeotForums.com is the premier Peugeot Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 29-10-12, 02:00 PM   #1
Senior Member
 
Join Date: Jul 2012
Posts: 2,061
Default heater control bulbs

hi all. does anyone know if the buttons on the heater control panel should light up?

on the back of the unit there is 3 bulbs. i tried swapping bulbs round but cant see to get them to light up.

its pretty difficult setting the heater with all the dark roads around here

its the one with the display if that helps

im hoping i can get this sorted before my sprayed centre console has dryed ready to go back in.

many thanks lee
monty9120 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 29-10-12, 08:40 PM   #2
Senior Member
 
jmkent's Avatar
 
Join Date: Sep 2010
Location: St Austell, Cornwall
Posts: 3,861
Default

Yes, should be lit up... if the bulbs are there but not working, then maybe they've blown? If they are like the ones on my old 306, they're only a quid or so to replace so may be worth a try.
__________________
407SW 2.0HDI 136 SE 2005
ex. 306 2.0HDI 90 (x2)
jmkent is offline   Reply With Quote Quick reply to this message
Old 29-10-12, 08:55 PM   #3
Senior Member
 
Join Date: Jul 2012
Posts: 2,061
Default

thanks. the cars in bits at the moment. when i swapped working bulbs round they still didnt seem to work. i even managed to break a fuse

im having an issue with electrics latelly so i will try to sort it
monty9120 is offline   Reply With Quote Quick reply to this message
Old 30-10-12, 12:01 AM   #4
Senior Member
 
Roky's Avatar
 
Join Date: Aug 2012
Location: Torquay
Posts: 323
Default

I'm so glad I found this thread. I was just about to ask the same question.

Good luck Monty. I'll be having a go at this now too.
__________________
307 SW SE HDI 110 (2003)
Roky is offline   Reply With Quote Quick reply to this message
Old 30-10-12, 11:05 AM   #5
Senior Member
 
Join Date: Jul 2012
Posts: 2,061
Default

i have received the bulbs this morning.

i will wait until its dark and fit them to see if they work.

the middle bulbs for the display work just not the buttons. i have a few days before it goes back together so will try and sort it if not ill source a new display

french electrics eh
monty9120 is offline   Reply With Quote Quick reply to this message
Old 30-10-12, 05:36 PM   #6
Senior Member
 
Roky's Avatar
 
Join Date: Aug 2012
Location: Torquay
Posts: 323
Default

Quote:
Originally Posted by monty9120 View Post
i have received the bulbs this morning.

i will wait until its dark and fit them to see if they work.

the middle bulbs for the display work just not the buttons. i have a few days before it goes back together so will try and sort it if not ill source a new display

french electrics eh
French electrics indeed.

I've just sorted my heater control panel. Turned out it's just one bulb supplying light to all the buttons, changed it and it's sorted.

Don't know why I didn't do it sooner.
__________________
307 SW SE HDI 110 (2003)
Roky is offline   Reply With Quote Quick reply to this message
Old 30-10-12, 06:17 PM   #7
Senior Member
 
Join Date: Jul 2012
Posts: 2,061
Default

i only asked cause my missus dad was in the car and he asked why they werent lit up.
i didnt even realise even though i was always messing about in the dark trying to work out what button was what
monty9120 is offline   Reply With Quote Quick reply to this message
Old 30-10-12, 07:51 PM   #8
Senior Member
 
Join Date: Jul 2012
Posts: 2,061
Default

i have fitted a new bulb

the one i have fitted is the only one that seems to work

i tryed to change the other 2 and it sparked and now no lights on the speedo will work.

i turned the car off and the lights. any ideas what fuse is needed. even the mileage doesnt work or the rev counter
monty9120 is offline   Reply With Quote Quick reply to this message
Old 30-10-12, 07:58 PM   #9
Senior Member
 
jmkent's Avatar
 
Join Date: Sep 2010
Location: St Austell, Cornwall
Posts: 3,861
Default

What year/reg is your car?
__________________
407SW 2.0HDI 136 SE 2005
ex. 306 2.0HDI 90 (x2)
jmkent is offline   Reply With Quote Quick reply to this message
Old 30-10-12, 08:18 PM   #10
Senior Member
 
Join Date: Jul 2012
Posts: 2,061
Default

its a 2001 51 plate. i have tried following the haynes manual but no luck

all lights work. the bsi just doesnt wake no speedo lights no mileage etc everything else is working
monty9120 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 12:12 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0