307 Airbag Fault. - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 307
PeugeotForums.com is the premier Peugeot Forum on the internet. Registered Users do not see the above ads.
Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 25-09-11, 09:41 PM   #1
Member
 
peugeotpete1's Avatar
 
Join Date: May 2011
Location: Truro, Cornwall
Posts: 96
Default 307 Airbag Fault.

I have recently been accompanied on my way to work with the Airbag Fault warning on the MFD with its light on the instrument panel..

I have been doing some searching on the net and have found a few pointers towards the Comm 2000 unit having faulty ribbon connectors etc etc i have also checked the seat belt tensioner connectors/seat bags under the seats and they look tight.. (mines a 3 door so they get alot of rag)

What i found weird is i performed a reset, disconnecting the battery following the bsi power-down procedure with a rough down time of 10 mins, and reset as instructed (turning on headlights yadda...)

the airbag light disappeared for two days!, an re-lit on my way home from work one day..
i used to be guaranteed the light on every start up, now it seems to vary journey to journey, sometimes it wont light at all...

If anyone can give me a few pointers what this could be it would be really appreciated..

Im gonna take it into the garage and get diagnostics ran on it sometime next week, in addition im pretty confident i can change the comm unit myself but any head's up on direction to a cheaper unit would be nice..


Thanks guys...

Oh and for some reason since owned every now and then i have to turn the key 2-3 times to get a start... it just seems to misfire and stall.
peugeotpete1 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 26-09-11, 06:05 PM   #2
Member
 
peugeotpete1's Avatar
 
Join Date: May 2011
Location: Truro, Cornwall
Posts: 96
Default

Diagnostics done today.. Intermittent fault Drivers Module level 2 - open circuit.
Comm 2000 shopping on thursdy..
__________________
206 1.9 LXD
307 Rapier 1.6
406 2.1 GLXTD
peugeotpete1 is offline   Reply With Quote Quick reply to this message
Old 30-09-11, 01:53 PM   #3
Member
 
peugeotpete1's Avatar
 
Join Date: May 2011
Location: Truro, Cornwall
Posts: 96
Default

not that anyone has looked or commented. i got a replacement unit, is working fine, however the replacement unit was a delphi type, replacing a dav unit, an easy way to identify the two the delphi unit has 3 alignment triangles on its bottom right..

In a nutshell the black connector on my car would not fit in the socket of the delphi unit (different mould type), i took the risk of cutting off the plastic pip that was blocking its entry and all works well (for those that have the same problem and are willing not to risk)
__________________
206 1.9 LXD
307 Rapier 1.6
406 2.1 GLXTD
peugeotpete1 is offline   Reply With Quote Quick reply to this message
Old 30-09-11, 07:20 PM   #4
Senior Member
 
Join Date: Dec 2010
Location: Woking, Surrey
Posts: 122
Default

Quote:
Originally Posted by peugeotpete1 View Post
not that anyone has looked or commented. i got a replacement unit, is working fine, however the replacement unit was a delphi type, replacing a dav unit, an easy way to identify the two the delphi unit has 3 alignment triangles on its bottom right..

In a nutshell the black connector on my car would not fit in the socket of the delphi unit (different mould type), i took the risk of cutting off the plastic pip that was blocking its entry and all works well (for those that have the same problem and are willing not to risk)
Thanks for the tip i have the same problem with mine and may need to swap out the com 2000. nice to know they can be interchanged.
stvstx is offline   Reply With Quote Quick reply to this message
Old 30-09-11, 10:59 PM   #5
Member
 
peugeotpete1's Avatar
 
Join Date: May 2011
Location: Truro, Cornwall
Posts: 96
Default

Yeah it seemed a little silly, but it worked and I haven't had any problems yet, the delphi units seem to be a better build quality, however the stalks are quite stiff on them and the indicator only cancels on the wheels return to 0 whereas the Dav units have a cancel trigger more often, which I've found to be slighty annoying.. Relatively easy ti change, just make sure you take the battery off in the correct order, and allow time for the airbag circuitry to discharge, you don't want it going off on its reconnection
__________________
206 1.9 LXD
307 Rapier 1.6
406 2.1 GLXTD
peugeotpete1 is offline   Reply With Quote Quick reply to this message
Old 02-10-11, 09:25 PM   #6
Junior Member
 
Join Date: Oct 2011
Posts: 21
Default

Pete did your airbag light go off automatically after you changed the comms 2000 unit or did you need to hook it to the machine to clear the fault codes off??
morrell48 is offline   Reply With Quote Quick reply to this message
Old 03-10-11, 12:31 AM   #7
Member
 
peugeotpete1's Avatar
 
Join Date: May 2011
Location: Truro, Cornwall
Posts: 96
Default

hi, yes it did although the warning light/buzzer etc did become intermittent after i did some tampering with the faulty comm 2000 unit itself, i took the unit out and measured the continuity of the ribbon cabling to find out which one was going o/c but never managed to find it... ive read somewhere that the lights can sometimes need a diagnostics computer to reset the light.
do just make sure that you follow the battery removal procedure and reconnection procedure if you do remove to do any tampering and allow time (at least 20 mins) for the airbag circuits discharge before removing them
ian livsey likes this.
__________________
206 1.9 LXD
307 Rapier 1.6
406 2.1 GLXTD
peugeotpete1 is offline   Reply With Quote Quick reply to this message
Old 03-12-12, 11:35 PM   #8
Junior Member
 
Join Date: Jul 2012
Posts: 25
Default

Mine also got this faulty. Had accident last two week but air bag not deploy. Just front driver and passenger seat belt tight.

Will send to diagnose. But i don't know how much will cost me for change the part. I'm from Asia and part is very expensive plus tax 200%.
zabidin2 is offline   Reply With Quote Quick reply to this message
Old 15-12-12, 10:59 AM   #9
Member
 
Join Date: Feb 2012
Posts: 47
Default

I changed my coms unit yesterday (307 HDi 90 bhp 02 plate), Ive never done anything like this before (I may have a few spanners but im not a mechanic), having used the forum many times to save myself a few quid I read all I could find on here and was a little worried about getting the wrong one for my car how ever I ended up taking a chance on one taken from an 03 plate that had just come into my local salvage/breakers yard.
I looked for the all important part number offered by those cleaver people on here who know what they are doing....couldnt find any numbers that matched the ones I was looking for :/ so bought the unit anyway as who knows when im going to see another 307 in my local breakers (been waiting over 4 months for this one). I set about working out how to take off my old unit...wasnt as hard as I thought but had to be careful with those fragile connectors and worked slow to be sure not to mess anything up!
The end result was about 40 mins of my time and I now have a working coms
When looking for a used coms unit I found plenty on eBay for 60 70+ with new units upwards of 140. The one I got from my breakers was only 25 and has solved my dashboard airbag light problem.....happy days!!!
__________________
2002, 307 LX A/C, 90bhp TDi, 5 door
vin:82498347

Last edited by Buzzard; 15-12-12 at 05:11 PM.
Buzzard is offline   Reply With Quote Quick reply to this message
Old 03-02-13, 05:57 PM   #10
Junior Member
 
Join Date: Jan 2013
Posts: 11
Default Thankyou!!!

just wanted to say thanks and wanted to share my little success.

i too had an airbag fault, permanent fault Drivers Module level 2 - open circuit

and after reading around on the forum, including this thread decided to buy a comms unit in the hope of sorting it.
well i got a delphi unit from a 307 from ebay 52 inc delivery (used)

with the help of this forum, i have now fitted the replacement comms, which also required a little bit cut off the black plug that goes into the back of the unit.
so now....
Airbag fault gone, cleared in planet also, hasn't come back!
trip computer.. didnt have that before- no button on old stalk!
Cruise control got the stalk on the new(used) unit, enabled in planet!

so im well happy with that one, all done for 52!
Thankyou forum members
k47l is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 07:37 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0