Help! 2007 Peugeot 207 1.4 electrics gone wild - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 207
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 19-05-17, 11:12 AM   #1
Junior Member
 
Join Date: May 2017
Posts: 18
Default Help! 2007 Peugeot 207 1.4 electrics gone wild

Hi, hoping someone can help for the past couple of days I keep getting verious warning lights one after the other come up on my dash, abs, braking system faulty, anti pollotion, power steering keeps failing engine management light come on, I don't know what to do! Or what's causing this I had my abs circuit bored reconditioned around two months ago everything was fine until 2days ago can anyone shed some light
Jade_b is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 19-05-17, 01:39 PM   #2
Senior Member
 
noddy-hol's Avatar
 
Join Date: Jul 2013
Location: cambs
Posts: 557
Default

Hi...as a start check all the battery terminals for cleanliness and make sure all are tight...check the earth wires to the body and gearbox...check battery voltage with a meter....good luck ..let us know
noddy-hol is offline   Reply With Quote Quick reply to this message
Old 19-05-17, 01:41 PM   #3
Senior Member
 
jimmymarsbar's Avatar
 
Join Date: Feb 2016
Location: Thackley, West Yorks
Posts: 1,702
Default

+1 to what noddy-hol said, read my reply to your other post too
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jimmymarsbar is offline   Reply With Quote Quick reply to this message
 
Old 19-05-17, 03:02 PM   #4
Moderator
 
storeman's Avatar
 
Join Date: Jan 2013
Location: Oldham, UK
Posts: 5,573
Default

+2 to the above. Random error messages and warnig lights is generally down to bad earth connections or a battery eithe failed or low charge.

A word of caution, a battery checked with a volt meter can appear to be good when it is idle. You need to see what the voltage drops to when trying to start the engine. On a bad battery, the 12 volts it shows when the engine is off and nothing powered on can drop well below 5 volts when the starter motor is turning the engine over.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
storeman is online now   Reply With Quote Quick reply to this message
Old 19-05-17, 03:45 PM   #5
Junior Member
 
Join Date: May 2017
Posts: 18
Default

Thank you I will take it to one of the garages and see if someone can do it for me
Jade_b is offline   Reply With Quote Quick reply to this message
Old 19-05-17, 03:50 PM   #6
Junior Member
 
Join Date: May 2017
Posts: 18
Default

Oh may I add I took my car to a local garage this afternoon didn't think to ask about checking battery.. and the local garage don't seem to have a clue what was going on they pointed at the ecu... they tried plugging my car into there computer but the car wasn't communicating at all could this also be due to the battery
Jade_b is offline   Reply With Quote Quick reply to this message
Old 19-05-17, 04:00 PM   #7
Senior Member
 
noddy-hol's Avatar
 
Join Date: Jul 2013
Location: cambs
Posts: 557
Default

I always start at the battery with any electrical fault...there may be something more serious going on...but its very easy to point to ecu's when its not easily fixed...I would look for a garage that has more peugeot experience...or a member local to you who can help,,,,whereabouts are you...?
noddy-hol is offline   Reply With Quote Quick reply to this message
Old 19-05-17, 04:06 PM   #8
Junior Member
 
Join Date: May 2017
Posts: 18
Default

I'm in wiltshire
Jade_b is offline   Reply With Quote Quick reply to this message
Old 19-05-17, 04:07 PM   #9
Junior Member
 
Join Date: May 2017
Posts: 18
Default

My partner has just informed me the ecu got replaced in march it was a reconditioned one tho with warrenty
Jade_b is offline   Reply With Quote Quick reply to this message
Old 19-05-17, 04:09 PM   #10
Junior Member
 
Join Date: May 2017
Posts: 18
Default

I'm starting to wonder if there could be a lose connection somewhere because I also took the car to the Peugeot dealer before I had the ecu replaced they checked the feeds and earth cables and pins and they said all of them where ok
Jade_b is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 11:45 PM.



Powered by vBulletin® Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.